What's New
Product Documentation

Enterprise Agent Installation for Cisco Catalyst 9000 Series Switches

This article details the steps to install the ThousandEyes appliance on a Cisco Catalyst 9000 series switch running IOS XE. The appliance is a pre-installed ThousandEyes Enterprise Agent with a web-based management UI, which can be quickly imported into a virtualization environment.

Requirements

  • A Cisco Catalyst 9000 switch with app-hosting support

  • An IOS XE version that supports app-hosting, as below:

    • Catalyst 9300 – 16.12.1

    • Catalyst 9400 – 17.1.1

    • Catalyst 9500 – 17.2.1

    • Catalyst 9600 – 17.2.1

      We recommend using the latest Extended Maintenance version, not the standard maintenance version.

  • DNA-Advantage licensing to enable app-hosting (see Application Licensing)

  • 2GB of free memory per installed appliance (see IOX application resource limitations)

  • 2 free vCPUs per installed appliance

  • Specified USB 3.0 SSD for the back panel (third-party USB drives in front panel are not supported), which needs to be mounted as usbflash1 (see Installing a USB 3.0 SSD)

  • A DHCP server or a static IP address for the appliance

  • Internet connectivity from the switch

  • Familiarity with Cisco Catalyst IOS XE application hosting. Review Cisco's Application Hosting instructions, if needed.

Overview

The installation process for an appliance consists of three steps:

The following example installs, activates, and initializes the appliance on a Cisco Catalyst 9300. In the example, the name of the virtual service is teva.

Installing the Appliance

  1. Log in to the ThousandEyes application, using a login belonging to the account group that will be associated with the appliance.

  2. Navigate to the Cloud & Enterprise Agents > Agent Settings and click Add New Enterprise Agent.

  3. On the Appliance tab, find the entry for Cisco IOS XE Container and download the TAR file for Catalyst 9000 Series Switches.

  4. Copy the file onto the switch using one of the following methods:

    • Secure Copy Protocol (SCP)

    • File Transfer Protocol (FTP)

    • Trivial File Transfer Protocol (TFTP)

    • USB storage device

  5. Enable the IOx framework on the switch, and wait until all the services are running:

    Enter configuration commands, one per line. End with CNTL/Z.
    Cat9k(config)#iox
    Cat9k(config)#end
    Cat9k#show iox-service
    IOx Infrastructure Summary:
    ---------------------------
    IOx service (CAF) : Running
    IOx service (HA) : Running
    IOx service (IOxman) : Running
    Libvirtd : Running
  6. Deploy the appliance from the package:

    Cat9k# app-hosting install appid teva package usbflash0:thousandeyes-va.cisco.tar.gz
    teva installed successfully
    Current state is: DEPLOYED
  7. Configure a single virtual network interface card (vNIC) for the appliance.

    Example of Configuration with AppGigabitEthernet Port in Trunk Mode

    1. Verify that the front panel data port is running, with VLAN allowed from uplink:

      interface GigabitEthernet1/0/13
      description Uplink MGMT
      switchport access vlan 21
    2. Create an SVI (Switch Virtual Interface) that matches with Layer-2 VLAN:

      interface Vlan21
      ip address 10.100.21.13 255.255.255.0
    3. Configure the AppGigabitEthernet port to allow Layer-2 VLAN:

      interface AppGigabitEthernet1/0/1
      switchport trunk allowed vlan 21
      switchport mode trunk
    4. Assign AppGigabitEthernet as app-vnic of the app:

      (config-app-hosting)#app-vnic AppGigabitEthernet trunk
      (config-config-app-hosting-trunk)#vlan VLAN 21 guest-interface 0
      (config-config-app-hosting-trunk)exit

    Example of Configuration with AppGigabitEthernet Port in Access Mode

    app-hosting appid teva
    app-vnic AppGigabitEthernet access
    guest-interface 0
    !
    interface AppGigabitEthernet1/0/1
    switchport access vlan 100
    switchport mode access
    !

Activating the Appliance

  1. Install, activate and start the IOx package containing the ThousandEyes appliance:

    Cat9k# app-hosting activate appid teva
    teva activated successfully
    Current state is: ACTIVATED
    Cat9k# app-hosting start appid teva
    teva started successfully
    Current state is: RUNNING
  2. Use the sh app-hosting list command to verify that the virtual machine has been installed and is in the running state:

    cat9k#sh app-hosting list
    App id State
    ------------------------------------------------------
    teva RUNNING
  3. Verify the virtual machine details:

    Cat9k#show app-hosting detail appid teva
    App id : teva
    Owner : ioxui
    State : RUNNING
    Application
    Type : vm
    Name : thousandeyes-va-64-16.04
    Version : 0.144
    Description : ThousandEyes Cisco Virtual Appliance
    Activated profile name : custom
    Resource reservation
    Memory : 2048 MB
    Disk : 20000 MB
    CPU : 1200 units
    Attached devices
    Type Name Alias
    ---------------------------------------------
    serial/shell iox_console_shell serial0
    serial/aux iox_console_aux serial1
    serial/syslog iox_syslog serial2
    serial/trace iox_trace serial3
    Network interfaces
    ---------------------------------------
    eth0:
    MAC address : 52:54:dd:27:84:b0

Configuring the Appliance

  1. Connect to the virtual machine console from the IOS XE command-line interface to configure Networking, if needed.

    Cat9k#app-hosting connect appid teva console
    Connected to appliance. Exit using ^c^c^c

  2. The default Network configuration uses DHCP. If you want to assign a static IP address, press 'N'. After the hostname screen, select "Static configuration parameters" using the down-arrow key then the space bar. Use the Return key to select 'OK'

    NOTE: To exit the console, press CTRL+C three times

  3. Once the network settings are applied, access the ThousandEyes virtual appliance interface through the URL in that screen and log in with the credentials shown in the virtual console.

  4. Upon login, you will be prompted to change the Web Interface password.

  5. Obtain your account group token: Navigate to Cloud & Enterprise Agents > Agent Settings > Agents tab, click Add New Agent. Then scroll down and click Show Account Group Token for Installation to reveal the token.

  6. Paste the account group token into the Account Token field.

  7. Select Yes for Browserbot if you wish; this is required for page load and transaction tests.

  8. Click Continue to review agent diagnostic results, and then Complete the setup.

  9. In the ThousandEyes application, check that your Agent appears on the Cloud & Enterprise Agents > Agent Settings > Agents tab.

That's it! You've installed an enterprise agent on your Catalyst 9000 Series Switch.