KVM Agent Installation for Cisco Catalyst 9000-Series Switches
This article details the steps to install the ThousandEyes appliance on a Cisco Catalyst 9000-series switch running IOS XE. The appliance is a pre-installed ThousandEyes Enterprise Agent with a web-based management UI, which can be quickly imported into a virtualization environment.

Requirements

    A Cisco Catalyst 9000-series switch with app-hosting support
    An IOS XE version that supports app-hosting, as below:
      Catalyst 9300 – 16.12.1
      Catalyst 9400 – 17.1.1
      Catalyst 9500 – 17.2.1
      Catalyst 9600 – 17.2.1
      We recommend using the latest Extended Maintenance version, not the standard maintenance version.
    DNA-Advantage licensing to enable app-hosting (see Application Licensing)
    2GB of free memory per installed appliance (see IOX application resource limitations)
    2 free vCPUs per installed appliance
    A DHCP server or a static IP address for the appliance
    Internet connectivity from the switch
    Familiarity with Cisco Catalyst IOS XE application hosting. Review Cisco's Application Hosting instructions, if needed.
To use the Cisco DNA Center to orchestrate agent deployment, ThousandEyes requires DNA Center version 2.2.2. Other DNA Center versions are not supported.

Overview

The installation process for an appliance consists of three steps:
The following example installs, activates, and initializes the appliance on a Cisco Catalyst 9300. In the example, the name of the virtual service is teva.

Installing the Appliance

    1.
    Log in to the ThousandEyes application, using a login belonging to the account group that will be associated with the appliance.
    2.
    Navigate to the Cloud & Enterprise Agents > Agent Settings and click Add New Enterprise Agent.
    3.
    On the Cisco Application Hosting tab, find the entry for Cisco IOS XE KVM Appliance and download the TAR file for Catalyst 9000 Series Switches.
    4.
    Copy the file onto the switch using one of the following methods:
      Secure Copy Protocol (SCP)
      File Transfer Protocol (FTP)
      Trivial File Transfer Protocol (TFTP)
      USB storage device
    5.
    Enable the IOx framework on the switch, and wait until all the services are running:
    1
    Enter configuration commands, one per line. End with CNTL/Z.
    2
    Cat9k(config)#iox
    3
    Cat9k(config)#end
    4
    Cat9k#show iox-service
    5
    6
    IOx Infrastructure Summary:
    7
    ---------------------------
    8
    IOx service (CAF) : Running
    9
    IOx service (HA) : Running
    10
    IOx service (IOxman) : Running
    11
    Libvirtd : Running
    Copied!
    6.
    Deploy the appliance from the package:
    1
    Cat9k# app-hosting install appid teva package usbflash0:thousandeyes-va.cisco.tar.gz
    2
    teva installed successfully
    3
    Current state is: DEPLOYED
    Copied!
    7.
    Configure a single virtual network interface card (vNIC) for the appliance.
    Example of Configuration with AppGigabitEthernet Port in Trunk Mode
      1.
      Verify that the front panel data port is running, with VLAN allowed from uplink:
      1
      interface GigabitEthernet1/0/13
      2
      description Uplink MGMT
      3
      switchport access vlan 21
      Copied!
      2.
      Create an SVI (Switch Virtual Interface) that matches with Layer-2 VLAN:
      1
      interface Vlan21
      2
      ip address 10.100.21.13 255.255.255.0
      Copied!
      3.
      Configure the AppGigabitEthernet port to allow Layer-2 VLAN:
      1
      interface AppGigabitEthernet1/0/1
      2
      switchport trunk allowed vlan 21
      3
      switchport mode trunk
      Copied!
      4.
      Assign AppGigabitEthernet as app-vnic of the app:
      1
      (config-app-hosting)#app-vnic AppGigabitEthernet trunk
      2
      (config-config-app-hosting-trunk)#vlan VLAN 21 guest-interface 0
      3
      (config-config-app-hosting-trunk)exit
      Copied!
    Example of Configuration with AppGigabitEthernet Port in Access Mode
    1
    app-hosting appid teva
    2
    app-vnic AppGigabitEthernet access
    3
    guest-interface 0
    4
    !
    5
    interface AppGigabitEthernet1/0/1
    6
    switchport access vlan 100
    7
    switchport mode access
    8
    !
    Copied!

Activating the Appliance

    1.
    Install, activate and start the IOx package containing the ThousandEyes appliance:
    1
    Cat9k# app-hosting activate appid teva
    2
    teva activated successfully
    3
    Current state is: ACTIVATED
    4
    5
    Cat9k# app-hosting start appid teva
    6
    teva started successfully
    7
    Current state is: RUNNING
    Copied!
    2.
    Use the sh app-hosting list command to verify that the virtual machine has been installed and is in the running state:
    1
    cat9k#sh app-hosting list
    2
    3
    App id State
    4
    ------------------------------------------------------
    5
    teva RUNNING
    Copied!
    3.
    Verify the virtual machine details:
    1
    Cat9k#show app-hosting detail appid teva
    2
    App id : teva
    3
    Owner : ioxui
    4
    State : RUNNING
    5
    Application
    6
    Type : vm
    7
    Name : thousandeyes-va-64-16.04
    8
    Version : 0.144
    9
    Description : ThousandEyes Cisco Virtual Appliance
    10
    Activated profile name : custom
    11
    12
    Resource reservation
    13
    Memory : 2048 MB
    14
    Disk : 20000 MB
    15
    CPU : 1200 units
    16
    17
    Attached devices
    18
    Type Name Alias
    19
    ---------------------------------------------
    20
    serial/shell iox_console_shell serial0
    21
    serial/aux iox_console_aux serial1
    22
    serial/syslog iox_syslog serial2
    23
    serial/trace iox_trace serial3
    24
    25
    Network interfaces
    26
    ---------------------------------------
    27
    eth0:
    28
    MAC address : 52:54:dd:27:84:b0
    Copied!

Configuring the Appliance

    1.
    Connect to the virtual machine console from the IOS XE command-line interface to configure Networking, if needed.
    1
    Cat9k#app-hosting connect appid teva console
    2
    Connected to appliance. Exit using ^c^c^c
    Copied!
    2.
    The default Network configuration uses DHCP. If you want to assign a static IP address, press 'N'. After the hostname screen, select "Static configuration parameters" using the down-arrow key then the space bar. Use the Return key to select 'OK'
    NOTE: To exit the console, press CTRL+C three times
    3.
    Once the network settings are applied, access the ThousandEyes virtual appliance interface through the URL in that screen and log in with the credentials shown in the virtual console.
    4.
    Upon login, you will be prompted to change the Web Interface password.
    5.
    Obtain your account group token: Navigate to Cloud & Enterprise Agents > Agent Settings > Agents tab, click Add New Agent. Then scroll down and click Show Account Group Token for Installation to reveal the token.
    6.
    Paste the account group token into the Account Token field.
    7.
    Select Yes for Browserbot if you wish; this is required for page load and transaction tests.
    8.
    Click Continue to review agent diagnostic results, and then Complete the setup.
    9.
    In the ThousandEyes application, check that your Agent appears on the Cloud & Enterprise Agents > Agent Settings > Agents tab.
That's it! You've installed an enterprise agent on your Catalyst 9000 Series Switch.
Last modified 2mo ago